Stuck on login loop

I’ve been using Zorin OS for about 2 weeks now. Still fairly new to Linux as a whole but I’m really enjoying it so far!
Unfortunately yesterday after booting into Windows for something, I was stuck on a login loop when booting back into Zorin. Basically what happens is I enter my password, the screen goes black and my manufacturer’s logo appears before it goes straight back to the login screen,
I researched for a few hours, trying practically every solution I could find before eventually deciding to backup and reinstall. That fixed it, but after a few hours it randomly logged me out and went back to the login loop.
When I booted Zorin up today it just went straight to terminal and I was unable to start even the login graphical interface at all without reinstalling gdm3 and xorg.

I am able to login to the unity graphical environment using lightdm just fine so I’m guessing this is some kind of gdm3 issue.

System:    Host: CTURN-LINUX-Z20t-C Kernel: 5.3.0-53-generic x86_64
           bits: 64 gcc: 7.5.0
           Desktop: Gnome 3.30.2 (Gtk 3.22.30-1ubuntu4) Distro: Zorin OS 15.2
Machine:   Device: laptop System: TOSHIBA product: PORTEGE Z20t-C v: PT16BA-00L017 serial: N/A
           Mobo: TOSHIBA model: PORTEGE Z20t-C v: Version A0 serial: N/A
           UEFI: TOSHIBA v: Version 5.60 date: 06/27/2016
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech K370s/K375s Multi-Device Wireless Keyboard status: Discharging
CPU:       Dual core Intel Core m7-6Y75 (-MT-MCP-) 
           arch: Skylake rev.3 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5999
           clock speeds: max: 3100 MHz 1: 600 MHz 2: 600 MHz 3: 600 MHz
           4: 600 MHz
Graphics:  Card: Intel HD Graphics 515 bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.20.5 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: [email protected]
           OpenGL: renderer: Mesa DRI Intel HD Graphics 515 (Skylake GT2)
           version: 4.5 Mesa 19.2.8 Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k5.3.0-53-generic
Network:   Card-1: Intel Ethernet Connection I219-LM
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
           IF: enp0s31f6 state: down mac: b8:6b:23:9e:2e:cb
           Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: e4:b3:18:9e:b8:94
           Card-3: Atmel usb-ID: 001-007
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1256.3GB (31.5% used)
           ID-1: /dev/sda model: SAMSUNG_MZNTY256 size: 256.1GB temp: 35C
           ID-2: USB /dev/sdb model: External_USB_3.0 size: 1000.2GB temp: 0C
Partition: ID-1: / size: 67G used: 12G (19%) fs: ext4 dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 67.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 255 Uptime: 50 min Memory: 2181.1/7752.9MB
           Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.201) inxi: 2.3.56 

Two questions…

  1. Does the login loop occur when you login using Wayland or is it just with xorg?
  2. During your painful hours of troubleshooting :disappointed:, did you try any of these suggestions? If so, what was the outcome?

The login loop also occurs with Wayland, but that had always been an issue so I just figured it was a hardware clash of some sort and didn’t bother looking into it.
A few of the suggestions I found said to delete .Xauthority and .ICEAuthority, but when I tried that neither of them existed. I tried sudo chown <user>:<user> .Xauthority as well but it didn’t do anything.

I see. I know you did a fresh install, but have you tried purging and reinstalling gdm3? Also, I assume you are dual booting with Windows based on your initial statement. I know I’ve personally run into weird issues when attempting to dual boot with Windows and Zorin. I wonder if you would encounter the same issue if Zorin was the only OS installed.

I’ve tried that but it didn’t do anything. Also yes, I’m dual booting with Windows 10. I would try a solo install of Zorin but I need Windows for my work. :,)

Is the guide on the Group Forum helpful?

[UPDATE 20.01.2020 - Have found another potential cause to this problem - corrupt files. I booted a recent install of Zorin Education 15.1 on works Notebook and had login loop. Started in Advanced | Safe mode and ran FSCK - it could not run automatically, stated it would need to run manually.
So at the root prompt you type:


fsck /dev/sda1

This is assuming there is only one hard drive in the machine - you would of course put the device label according to which drive Zorin is on.
fsck runs and reports file errors in inodes and asks if you want to repair - well yes, you do obviously! Enter ‘y’ for any other prompts - it will tell you when you have finished. On completion of the task you will be returned to the safe mode options menu - don’t select ‘RESUME’ - turn off the machine and power up - problem solved! :D ]

The ‘de facto’ solution usually is to boot into advanced | recovery mode then from the recovery memory launch ‘root’ (terminal) then enter:


mount -n -o remount,rw /

then press Enter.


passwd your_username

then enter new password, shutdown and reboot.

If this does not work, and if you have Timeshift installed (can’t remember if Zorin includes this) then boot from live DVD/memory stick and point to where the snapshots are held and see if that works. If it doesn’t try one of the following 3 options (acknowledgements to … -loop.html? )

"Method #1 Fix Ubuntu login screen loop

The first is quite simple. The file is located under the current user’s home directory. All you will have to do is change the owner of .Xauthority file.

Step 1 - At login time, use Ctrl+Alt+F3 to switch and access the command line interface mode.

Step 2 - Login into the shell using your username and your password. In this case, username will be your username you set when you installed Ubuntu.

Step 3 - Once logged in, now run ls -lah to view list directory contents. Look for the line that ends with .Xauthority


# ls -lah-rw------- 1 root root 53 Nov 29 10:19 .Xauthority

Step 4 - You need to do chown. Type and run the following command :


['sudo' if not currently 'root'] chown username:username .Xauthority

Now reboot and see if you can log in - if not:

Step 5 - If it does not work, try renaming.


mv .Xauthority .Xauthority.bak

Now reboot and try re-logging in.

Method #2 How to Fix Ubuntu login screen loop

Step 1 - Run ls -ld /tmp. Check for the first 10 letters in the left: they should read exactly so: drwxrwxrwt


# ls -ld /tmpdrwxrwxrwt 15 root root 4096 Nov 30 04:17 /tmp

Step 2 - You may need to changing permission. Run the command below :


sudo chmod a+wt /tmp

Method #3 How to Fix Ubuntu login screen loop

If even both did not work for you, try the last one! Please make sure you are connected to active internet. Check this out!

Step 1 - Uninstall and reinstall Ubuntu lightdm. Run the following :


sudo apt-get purge lightdmsudo apt-get install lightdmdpkg-reconfigure lightdm

Step 2 - Once reconfigured, now reboot."

[I have modified the instructions as it is not clear at which point you become ‘root’ using the ‘sudo’ command - if the last element of a terminal prompt is ‘#’ then you are in the terminal as ‘root’ with elevated privileges. If the last element of the command prompt is ‘$’ you are a standard user, and not ‘root’. I have written this tutorial experiencing just this and used Method 1 which solved the issue for me in FerenOS]