ZorinOS, based on Ubuntu 20.04, stuck on the Zorin splash screen

New to Linux. Will try to keep this concise.

After using Zorin today, I accidentally hit the logout button, and it dropped me into the tty. But before the tty became interactable, i.e, before I could start typing in it, it hanged on me. I hit the power button and forcefully closed the laptop, then tried to boot into Zorin again, but then it just kept getting stuck at the Zorin splash screen.

Tried to do the following -

  1. Went into the terminal as root through recovery mode, and checked the status of gdm. Started gdm, and then on checking the status, it said gdm active, but it also said gdm couldn’t access dkms. Tried installing/updating dkms, to no avail.

Configuration/specifications -

  1. Kernel : 5.8.0-53 generic
  2. Architecture : x86_64
  3. ZorinOS : based on Ubuntu 20.04
  4. Hybrid graphics :
    i) Dedicated - Nvidia GTX 1650, Driver version - 460.73.01
    ii) Integrated - Intel UHD 630
  5. Display manager : gdm
  6. Dekstop Enviroment : Gnome
  7. Is dual booted with Windows 10

From the Recovery menu prompt, did you also try reinstalling GDM3?

sudo apt install --reinstall gdm

Are you able to boot into Windows normally?

Yes, I am able to boot into Windows normally. No problems or data loss so far that I’ve noticed.
Will try that and update.

Edit :
I seem to have fixed the problem. Although not through reinstalling gdm.
I uninstalled and reinstalled dkms, and rebooted. It booted me into the machine with the open Nvidia drivers. I have now installed the proprietary drivers without any malfunctions so far. Thanks for the help :slight_smile: