Zorin not beginner friendly enough yet?

Hi everyone,

I’ve seen and read some great Zorin OS reviews the past 2-3 years or so and as my retired dad(who also is Dutch so wanted a Dutch OS) wanted to make a switch since his hardware doesn’t support Windows 11 I thought it would be a good fit since it takes a lot of the Win experience.

So I’ve set him up with a clean install of Zorin OS 16 Core as his first Linux experience and monitored his first few days using it.

Don’t get me wrong, it’s a close to perfect experience in comparison with other distros and I really love the look and feel of Zorin which is why I want to share my findings so it could be improved upon so my dad can use Linux instead of Windows.

Here’s my findings:

  • The first launch tour had some terrible (auto translated?) Dutch in it and didn’t feel polished since it had some spelling errors and missed some capitalization. So I’ve immediately joined the poeditor site to help improve these localized sentences.

  • After this my dad noticed he had a hard time reading things like the date/time bottom-right and all text in the “start” menu when you click the Zorin logo button bottom-left.
    So this sent us on a mission to mess around with the font settings in Zorin Appearance, the 4 font options in this tool didn’t impact the size of the “start” menu at all.
    Luckily we found the big letters option in the regular accessibility settings but this was almost good enough.

So being stumped after those options it was useful that I knew about Gnome Tweaks(but of course my dad would have been stuck at this point). After installing that through the Software store we could edit the scale factor and that set him up with the font thing.
My dad noticed the little accessibility person in the taskbar with the big text enabled and asked “so I can turn it off and on over here?” and naturally after toggling the big text slider the item in the taskbar disappeared which took him a while to find the setting again in the settings menu(being able to pin that accessibility menu to the taskbar would be great!). He changed his wallpaper as well while going through settings and then we were off to the next challenge!

  • The next thing we ran into was installing something himself through the software store.
    He wanted to install Telegram which he could easily find in the store.
    After clicking Telegram however the store greeted us with an endless loading screen like this:

We reconnected WiFi, retarted the Store and tested some websites but it wouldn’t continue ever.
That’s when we switched to the updates tab and did our first ever batch of updates which went flawlessly, after which we rebooted the pc.

After this we could get to the Telegram application page, my dad was a bit confused about the possible installation sources options dropdown, but went with the default selected option which was the Flatpak I believe. He filled in his password when prompted and it looked like we were off to install it!
This next part might have been about an update instead of installing something through the store, after later installing OBS Studio through the store we noticed there actually WAS a progress bar.
This opened up the next beginner friendly problem, besides the word “installing” there is no other visual feedback that something is being done in the background. He was convinced something had crashed and that he needed a reboot because the application being installed just sat there for minutes. This would be a good addition to show some sort of installation progress bar so beginners know that something is happening.
It did install in the end because my dad already found it in the start menu before the software store showed it was done installing.
App launched perfectly fine and he did some Telegramming after setting it up.

This point leads me straight into the next one because literally the next day there was an update for the Telegram application in the store and my dad told me he couldn’t get the update done.
He clicked on install update for this Telegram application since it was the only available update and this is what it showed for about 24 hours:

The text “installed”(or “Wordt geïnstalleerd” in Dutch) is shown but no visible progress anywhere, the cancel button(“Annuleren” in Dutch) is greyed out and can’t be clicked, the store is stuck in an infinite check for new updates top-left (“Controleren…”) and the stop button over there doesn’t do anything.
So this already seems like a big problem for people who never touched a terminal in their lives and wouldn’t want to any way.
Closing the store and reopening doesn’t fix the issue.

On top that my dad points me to this new red thing in the taskbar which shows a big fat permission denied error and the suggestion to solve it in a terminal:

This seems to me like more of a Gnome Software store problem than a Zorin one to be honest but it is something that just can’t be fixed by beginners switching over from Windows that are used to all things GUI. So bottom line is if I were to leave this installation of Zorin on his pc without helping him solve it in a terminal he could have this update issue forever and a broken software store on top of it which makes him unable to install proper updates or new applications.

I’ve suggested him to do a reboot in the meantime to see if that might fix the broken updates and see if he can resume his Linux journey on his own without help from someone with more Linux experience.

Will keep you updated on it to see if it’s a dead end or that the ages old “have you tried turning it off and on again” will have to be the advice to him whenever he runs into issues again.

Hope this gives the devs some insight into a senior noob that tries Zorin for the first time!

Here with an update!

My dad tried rebooting several times and retried to install updates for the Telegram application in the Software store but it was a dead end.
The checking for updates stays in an infinite loop and the Telegram app update never gets done. And because the checking for updates never seems to stop it’s also impossible to get to the page of an installed app because all that is shown is a blank loading screen. Plus the “remove/uninstall” option isn’t there anymore because the Telegram app thinks it’s in the middle of installing an update.

So unfortunately day 2 of Zorin OS is where the Linux experience fun ends for him as a Linux beginner.

I know most of the more experienced Linux people have the saying that you should take the time to learn more about the operating system you use but for the majority of people switching over from mac/win this isn’t necessary since they either give a big fat vague popup that says something went wrong or things work again after a reboot.

I’m not sure if this is a Gnome related issue or a Zorin one but I’m really looking forward to a fix so we can get the moms and dads to switch :slight_smile:

Thanks for reading about our short Linux journey!

I would highly recommend starting out on Zorin OS 16 Lite. It is much easier to find things and configure things on.
Gnome is a lot like Windows… It does not let you do or change many things.
However, on Lite, we can increase the Font sizes or DPI, use WhiskerMenu (I make mine huge) easily and resolve several suggestions more easily than on core.

100% agreement. Gnome-Software most closely resembles the Windows Store. However, I never use the thing. It is non-verbose and that can create a lot of headaches.
I also avoid Flatpak and Snap, both. They are offered as options because Ubuntu Canonical (Snap) and RedHat (Flatpak) push those packages, desperately wanting users to switch to using them instead of the standard APT. Sound like Microsoft?

Run in terminal

sudo apt update && sudo apt upgrade

But this May Not resolve Flatpak issues… as I mentioned… it really is better to avoid Flatpak and Snaps unless you have no alternatives.
In my opinion.

Any New Journey requires learning and will come with frustration. This is inevitable.
And simply must be accepted. Just as any journey can come with traffic or being tired at the end of the day. We do not fail to make journeys because they make us tired any more than we fail to bathe because we might get wet. There is no real way of using a new system without needing to learn what things are and how to use them and what different things mean.
Please feel free to browse over at forum.zorin.com to find the Offical Zorin OS Forum and additional help.
Otherwise, may your other explorations into Distros or Operating Systems bring you success.

1 Like

Thanks for your detailed response Aravisian :smiley:

I was looking through the differences between Lite and Core but the only thing I can find is that is uses XFCE instead of Gnome.
So I understand that it’s more customizable because of that, even though me(and my dad) very much prefer the polished look of Gnome it’s something to try out especially for the font size(I did make it huge with the scaling in Gnome Tweaks though but feels like something that should be in settings or Zorin Appearance by default, at least there should be a font option that changes the start menu font size as well).

And I totally understand your feelings/frustrations about Gnome Software, I myself use the terminal over it to install things, but for people like my dad that are used to GUI everything and just want something that works it’s not ideal. It’s also a step that would keep most people away from desktop Linux (I mean for a majority of older people the switch from closed source Microsoft Word to an open source alternative is already a big change, commands in a terminal feels a step backwards or too alien for them) and I thought the store experience on Zorin would be a perfect one since it’s so highly recommended by the Linux community(and Linux YT channels) as a beginner distro.

For the update issue I’ve made a bash script on the desktop that can run with a click on it that does the updating for him(piping his pass to apt) in case it ever breaks again.
Running that and rebooting made it possible to remove the telegram flatpack(the update still didn’t work btw, I thought flatpack/snap were made to run flawlessly on any distro xD) and installed the zorin(.deb) version of telegram instead.

Wouldn’t launch with the launch button in the store though(which would be something my dad would think is broken again) but it does launch when launching from the task bar.
Hopefully this version will be able to update!

With this workaround I’ll give it another go for a while and suggest to my dad he should try to select the Zorin packages when installing something if there is a dropdown menu available. And always launch applications from the taskbar after being installed.
I think these tips/workarounds should make it usable for him.

Will report back after he’s used it for a while or if we decided to change to Zorin Lite / another distro.

At least thanks for the reply and suggestions, appreciate it!

1 Like