(PLEASE HELP) **Unable to install GRUB in dev/sda**

Lenovo Ideapad 320 15IAP; Zorin OS Lite 15.2
New to everything regarding linux. Want dual boot with windows 10 on UEFI (GPT). Fast startup, secure boot, fast boot - all disabled (tried enabling, same problem). Boot mode set to UEFI (already tried Legacy, same problem). Tried manual partitioning, same problem. Tried installing the GRUB bootloader on EFI partition where the Windows Boot Manager is, same problem (P.S. I enlarged the 100mb partition to 2048mb so the size is not a problem, same error). Tried automatic partitioning. Tried having less than 4 primary partitions. I literally tried everything I could find on the internet and could think of myself, nothing helped. Also checked the USB for corruption, no problems there.
Assistance much appreciated.
P.S. for a tad bit more detailed problem: https://www.reddit.com/r/zorinos/comments/hx0yp7/assistance_needed_in_installing_zorin_os_lite_152/

Aside from our fiasco on the Zorin Group Forum;


There are a LOT of them and you already mentioned having tried the suggestions read in most, such as using Legacy instead of UEFI and so on.
For what it is worth- You are not alone in experiencing problems on Lenovo Ideapad 320 with a linux distro.