I can't update my system anymore

I’m trying to update my system but it says “Downloading repository information fails
Check your Internet connection” but my internet is completely fine! I try to do it from terminal and it gives the following error;
W: GPG error: http://ppa.launchpad.net/savoury1/dbgl/ubuntu bionic InRelease: the following signatures could not be verified because the public key does not exist: NO_PUBKEY 374C7797FB006459
E:’ http://ppa.launchpad.net/savoury1/dbgl/ubuntu Bionic InRelease’ store unsigned.
N: no secure update can be made from such a repository, so the repository has been disabled.
N: detailed information about Warehouse creation and user configuration can be found on the apt-secure(8) guide page.
Also that panel glitch (blueman and riseup don’t appear) is back. I know Zorin for the most part developed my two people but… c’mon man.

" but… c’mon man."
Chuckle… I feel ya.
First things first:
“Downloading repository information fails
Check your Internet connection”
Don’t worry about it. I know- that message is an attention getter. But, I assure you, you are getting updates.
Let’s check my claim, first. In terminal, please enter
“lsb_release -a” without the quotes.
It should print your version as Zorin 15.1 (Not 15). If it does, you have been getting your updates.
Ok, so WHY are you getting that message? Sadly, it is a Gnome-Software bug that has been around for quite awhile. All Linux Distros that use Gnome-Software on the Gnome Desktop Environment are susceptible to getting this message and the message is in error. Gnome has not yet resolved this bug. And people ask about this issue very often.
On the Ubuntu PPA’s not being verified:
Please add the apt-repository for Rob Savoury:
sudo add-apt-repository ppa:savoury1/graphics
sudo add-apt-repository ppa:savoury1/multimedia
sudo add-apt-repository ppa:savoury1/ffmpeg4
Then Remove the Ubuntu PPA for Savoury and see if that resolves the issue.

On the Gnome Panel issue:
Can I bluntly ask, what would happen if you tried using XFCE4 panel, instead?
If you are willing to test it:
“sudo apt-get install xfce4-panel”
For testing, I would recommend placing the panel at the Top of your screen and I can help you with full walkthroughs on the settings of the panel. But I wonder if using it may show the RiseUp and Blueman icons consistently, and if so, if that may be a clue to the next step.
EDIT:
Ok, maybe I spoke too soon. I just checked this thread:


It suggests you are using the XFCE panel.
Well, Nutz.
Let me try researching this in depth.

I know how to use xfce. But Zorin already takes quite some time to load. When I use another desktop it takes even longer! (With Plasma it almost took 2,5 minutes to boot!) This is why I stick to GNOME. Why GNOME breaks this often by the way? Is there a problem with development? I’d switch to another distro but I don’t have a spare flash to do backup and my drive accounts are mostly full.

XFCE should load more quickly. You may see a slower boot time if you are running with Both Desktops installed.

You might try editing /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash noresume”
Then
sudo update-grub

XFCE doesn’t look very pretty. Are there any themes you recommend?

I really cannot recommend any themes because tastes vary a lot. I have no idea at all what you consider pretty or ugly.
XFCE has a lot more options for themeing, as it still uses a Window Border with the Window Manager allowing you to download XFWM themes for the borders or Desktop themes that include the XFWM window border files.
You can check out xfce-look.org and browse until something tickles your retinas. You might even come across something I uploaded.
You have MUCH greater control over the panel and you can select just about any background you like, from an image file to a color or transparent, opaque… You can set the panel to go opaque when not in use, as well. You can configure it to any size and in any position on the screen that you want, as well. You can make it a square off to one side or a long screen spanning single row, double row…

I fixed the update problem with the ppa you gave but the panel is the same. So I installed MATE but it doesn’t appear on login screen. sigh… Thanks GNOME you have ruined my distro! I think I should consider Linux Mint.

LOL, I have installed Mate, as well. So I can tell you it’s a little funny. Both installing it and uninstalling it require extra steps.
you must specify “sudo apt-get install mate-desktop-environemnt”
and “sudo apt-get install mate”. I cannot recall all the hoops off the top of my head at the moment. If you are not seeing it on login and are thinking about uninstalling it, just reverse your install from earlier and that will uninstall. The hoops happen when you successfully install it and it shows up on login.
I have also installed Cinnamon D.E. on Zorin and I will admit, it works very smoothly, on my machine. I install it and uninstall it often (Which you’re not supposed to do) in order to work on projects for Cinnamon.
My only complaint about Mints Cinnamon D.E. is that the panel is too gnome-like for me. To change it, you must use a Desktop Theme. You cannot customize it at will as you can with XFCE. It’s too… Box package deal and less Legos, if you catch my meaning.
Mint also puts things in different places than its peers which make it odd when you are used to following a certain path to suddenly have to use a different one.
Mints Support and Stability are Outstanding.
The perk of installing Cinnamon on Zorin, not only do they go well together, but it solves the File path problem above.
It never occurred to me until this moment to try using Mint D.E. with XFCE 4.12 Panel… I think I am going to try that, now.

OK, you are attempting to use a 3rd Party Repository provider that is not an official Ubuntu one and the author himself states he wrote it specifically for Mint 18.1 Serena MATE:

https://launchpad.net/~savoury1

That is your answer to your problem!

Just as Opera, being closed source, will not update through the official ‘Software Updater’.

Actually, Swarf, he is using that Repo because I suggested it since the official Ubuntu Repo is not working…

sudo apt remove --auto-remove *mate*
To remove mate in full. That one actually worked and removed pretty much EVERYTHING mate-desktop.