[HELP] "Unable to get list of updates"

Hi guys,

I’m brand new to Linux, so please bear with me. I was trying to update Zorin through the software manager and it gave me the following error message: “Unable to get list of updates”
image

I ran sudo apt update & upgrade and it threw up some error messages pertaining to the wine repositories, so I unchecked those in Software and Updates.

Now, the “Unable to get list of updates” message still shows up BUT, if I use the software updater, it runs fine and says that my computer is up to date.
image

I also ran sudo apt update and upgrade after unclicking the wine repositories, which similarly came out pretty clean.
"
Hit:1 https://repo.steampowered.com/steam stable InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 http://ppa.launchpad.net/kisak/kisak-mesa/ubuntu bionic InRelease
Hit:5 http://dl.google.com/linux/chrome/deb stable InRelease
Get:6 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:8 http://ppa.launchpad.net/lutris-team/lutris/ubuntu bionic InRelease
Hit:9 https://packages.zorinos.com/stable bionic InRelease
Hit:10 https://packages.zorinos.com/patches bionic InRelease
Hit:11 http://ppa.launchpad.net/zorinos/apps/ubuntu bionic InRelease
Hit:12 https://packages.zorinos.com/apps bionic InRelease
Hit:13 https://packages.zorinos.com/drivers bionic InRelease
Hit:14 http://ppa.launchpad.net/zorinos/drivers/ubuntu bionic InRelease
Hit:15 http://ppa.launchpad.net/zorinos/patches/ubuntu bionic InRelease
Hit:16 http://ppa.launchpad.net/zorinos/stable/ubuntu bionic InRelease
Fetched 163 kB in 2s (83.9 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
"
I tried to be as clear as I could - again, I’m completely new to Linux/Zorin, so any help will be appreciated!

You were very clear and you were also completely on the right track.
The issue is caused by repositories or a repository not ‘replying’ to the ping.
In unchecking the offending repo’s, you confirmed this. I would suggest going back into the Software & Updates app and selecting the wine repositories and Removing Them Entirely (Click the Remove button). Then update the cache and re run the sudo apt update in terminal.
If you still have WINE installed and are using it, your next step is to add the Proper Working Repository. However, Zorin OS includes “Zorin Windows App Support” which is the Zorin offered build of WINE, supported in the Zorin Repository. If this was me… I would completely uninstall / remove WINE. Then, in terminal or using Synaptic Package Manager, install Zorin Windows App Support.
Then in terminal run sudo apt full-upgrade to ensure all packages are fully up to date. Reboot and test that everything is working.

If you prefer to stick with WINE you need the key and the repo

wget -qO- https://dl.winehq.org/wine-builds/winehq.key | sudo apt-key add -

sudo apt-add-repository ‘deb http://dl.winehq.org/wine-builds/ubuntu/ bionic main’

Thanks for your detailed and fully considered reply! I actually got frustrated, formatted everything, and installed Ubuntu instead, which is running smoother for me (which is very likely due to simply me being more familiar with Linux at this point).

Again - I appreciate the help!

1 Like