Error while setting up custom brightness keys with xbacklight

I’ve always used This tutorial (https://askubuntu.com/questions/798203/changing-screen-brightness-through-keyboard-functions-on-my-notebook) on all previous distros I’ve used to set up custom keys to adjust brightness

But it’s giving me errors on Zorin Lite

$ sudo apt install xbacklight
[sudo] password :
Reading package lists… Done
Building dependency tree
Reading state information… Done
xbacklight is already the newest version (1.2.1-1build2).
The following packages were automatically installed and are no longer required:
libegl1-mesa libfstrcmp0 libllvm9 libtorrent-rasterbar9 python-cryptodome
Use ‘sudo apt autoremove’ to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
$ xbacklight -get
No outputs have backlight property
$ xbacklight -set 50
No outputs have backlight property
$ xbacklight -inc 10
No outputs have backlight property

This thread has a pretty thorough walk-through on this issue:

1 Like

This worked for me

Check your /sys/class/backlight folder. If you can see an intel_backlight folder there and still you are getting the above error then creating a /etc/X11/xorg.conf file with the below configuration should work for you. It worked for me.

Section "Device"
    Identifier  "Intel Graphics" 
    Driver      "intel"
    Option      "Backlight"  "intel_backlight"
EndSection

Also, remember to logout and login again for the changes to take effect.