Dualboot audio issues with Windows/Zorin

Hello, this seems like a frequent question but I am still running into trouble with the audio on a dual boot windows/linux system. I have windows 10 as a primary install and made a partition for Zorin OS 16 Core and I am using Grub2win as a bootloader. Upon installing Zorin, I had issues with my audio (no audio except from headphones (front 3.5mm jack) and HDMI to TV) i.e. my rear 3.5mm jack was not recognised or played sound (despite the settings menu appearing to be playing audio).

I am still very new to linux so I went online for help and found many examples of this issue but many say this should have been fixed in the updated linux kernel.

I jumped into Pavucontrol (changing outputs, disabling the HDMI output, HDAJackRetask (changing audio channels, Jack detection setting), ALSAamixer (checking mute settings, upping volume on all devices), and eventually hda-verb commands. None of these seemed to work (except for the HDA-verb commands, but they also messed up my audio in both Zorin and windows - both front and back 3.5mm jacks say they are unplugged and do not play audio). Now in both Windows and Zorin, only the Nvidia HDMI output is available for audio out.

I have tried this solution which advises to reset ALSA, pulsmixer and to add an option to the ALSA config file, but none of that seems to work for me.

The audio devices in Zorin were jumpy and glitching between the HDMI output and another output which I could not view in the settings. This caused choppy audio when it played through the HDMI to my screen speakers.

Redownloading the Realtek codec in windows did not reset any drivers as I hoped and I still have no way of detecting audio devices plugged into the 3.5mm jacks. The Realtek website also says the driver from there is for older kernels (3.18 or older) so I have not tried that.

Upon looking deeper into the HDA-verb commands I think I have messed up something with the hardware address pins, or the allocation of addresses in the audio bus or audio codec. I have not found a way to reset these to restore my codecs, firmware or anything else back to factory so that I can at least have my sound working in windows again while I try and fix the issues in Zorin. This seems like the primary fault I am dealing with. Is there anyway to undo the HDA-verb commands? Or set them to the right values? How do I find those values?

My audio card is a ALC887 VD. Any advice would be appreciated.

P.S. New to linux