Cannot set default applications

I have installed Visual Studio Code and would like to use it as my default text editor. However, I cannot seem to set it as the default text editor because there is no option to do so in the Select Application window.

image

I can select Visual Studio Code and the file will open as expected, but if I close Code and try and open the same file, it opens up in Text Editor instead.

The Default Applications settings page also doesn’t help, since there is no option to set a default text editor or an option to bind applications to file extensions.

How do I set default applications in Zorin?

Pyroglyph, if you right click the item you want to open, but select “Properties”, then from that point select the “open With Default.” If that does not work, then we can try doing some Mimetype Editing in your ~./local folder.

1 Like

Ah, that’s worked. Thank you very much! It seems odd that there isn’t the ability to set a default application in the Select Application window but there is in the properties (since the properties window is usually used for per-file settings, not global defaults).

Now I can finally stop VLC from trying to open various text files! I have no idea why it was set to do that by default in the first place

I understand completely. In Zorin Lite (XFCE) it is done in exactly the same manner that you describe. Makes more intuitive sense.
For me, it is Firefox always being offered to open image files. Drove me nuts. Had to fix that by adjusting the mimeinfo.cache because the mimetype editors all only offer to change only ONE mimetype instead of all the ones listed as alternatives.
And no idea why Firefox felt the need to set itself as an option to open Image files.